業界最高年齢社長Halのゲーム日記 その623 S.T.A.L.K.E.R. SOCのアップグレードとダウングレード編

2013/2/13 | 投稿者: hal

S.T.A.L.K.E.R.Shadow of Chernobyl SOCのアップグレードとダウングレード方法について。

S.T.A.L.K.E.R.というゲームはMOD生命であり、MODがないと魅力は半減する。 なにせMODを入れると、元のゲーム(バニラという)とは主人公も違えばストーリーも全く異なる、ほとんど新作ゲームに近い状態にまでなってしまうという、希有のゲームなのだ。 そんなMODが幾つもあるのが、このS.T.A.L.K.E.R.の最大の魅力である。

つまりは一粒で二度どころか三度でも四度でもおいしいという、嬉しいゲームである。 これにはまると二度とゾーン(S.T.A.L.K.E.R.の舞台)から出られなくなり、ロシア語で助けを呼び(パマギーチェ!)、ゲームをプレイする時にはガスマスクをかぶってするようになるという、とんでもないゲームである。


S.T.A.L.K.E.R.SOCでは本体のバージョンが幾つかあり、MODが対応しているバージョンはまちまちである。 バージョンは1.0003・1.0004・1.0005・1.0006と4つもある。 ほとんどのMODは1.0005でOKだが、中には1.0004でなければ不可とか、パッチを当てると1.0006でないと落ちるとかいうものもある。 流石に1.0003でないと動作しないというMODは現在ではないようだ。 

FAIAKESなどは1.0004でないと動作しなかった。 逆にReturn of Scarのパッチ3は1.0005ではCTD、1.0006では問題なかった。 そのため複数の本体バージョンを用意しておいた方が良い。

SOCの場合MODを入れることを前提にするなら、これからS.T.A.L.K.E.R.を買って見ようかという方にはパッケージ版をお奨めする。 STEAM版はアップグレードは簡単だがダウングレードが面倒なのだ。

但しパッケージ版でも、ものによっては最初から1.0006になっている場合がある。 なので1.0003又は1.0004のものを選ぶべきだが、それを事前に知ることはまず不可能である。 

おおよそのところは、対応OSがVista或いは7になっている場合は、1.0006にアップされている可能性が高い。 対応がXP以前ならば、1.0003又は1.0004の可能性が高いが、これも絶対確実な見分け方ではない。 

不明のまま購入したら1.0006になっていた場合は? すんません、オイラにはどうしようもないので、別の版を購入するしかなさそう。 事前にバージョンを判別する方法か、或いは1.0006から無理矢理にダウングレードする方法があればいいのだが・・・

「無理矢理ダウングレード」は、要はbinフォルダの内容とパッチ情報ファイルがあればよいのだが、これを勝手にアップロードするのは法的な問題がありすぎるので、不可能だろう。

時間が経つと1.0006のパッケージが更に増えそうなので、STEAM版しか持っていない方、或いはこれから購入しようかと考えている方は、早めに購入して置くことを強くお勧めする。

又パッチの種別ではUS版とww版(world wide)があるので、購入したパッケージを調べて間違えないようにする。 ww版は「multi」と書かれる場合もある。 アメリカ以外からの輸入盤はほぼww版である。

-----------------------------
■ SOCのアップグレード法

私がDLした時のSTEAM版は1.0005だった。 この1.0005は大半のMODに対応しており、これ一つでほとんどのMODがプレイできる。 しかし現在は1.0006になっているようで、これに対応しているMODは数少ない。 

しかもこれをアップすると元にもどすのに手間がかかる。 一応ツールはDLしてあるが、これが1.2GBもあるでかいものだ。 なのでまずはパケ版の1.0004を購入し、1.0006迄アップしてゆくべきだろう。

------------------------------------------------------
■パケ版でのバージョン設定
購入したバージョンが1.0003だったとする。 これを1.0004-1.0005-1.0006とパッチを当ててアップしてゆくのだが、パッチのDL先がばらばらで探しにくい。

■パッケージ版パッチDLサイト
1.0004-1.0005
http://www.gamecopyworld.com/games/gcw_index_3.shtml#S
1.0006
http://stalker.zoo.co.jp/download.php

■STEAM版ダウングレードDLサイト(要会員登録 このmoddbにはS.T.A.L.K.E.R.に限らずFalloutなどの各種MODが揃っているので、会員登録をお勧めする)
http://www.moddb.com/mods/zone-of-alienation-mod/images/downgrading-your-soc-from-10005-to-10004#imagebox

------------------------------------------------------
■手順 ここでは1.0003から順次アップしてゆくものとする

0 ■重要! インストールしたゲームのbinフォルダをリネームコピーしておく。
 例:bin - bin10003 など(購入したゲームのデフォルトのバージョンが1.0003だった場合)

1 DLしたパッチ1.0004を当てる 通常はパッチが自動的にインストールフォルダを探してくれるが手動の場合もある。

この場合変更はbinフォルダとgamedata.db*である。 binの内容(エンジンとDLL)がアップデートされ、gamedata.db*(gamedataフォルダの内容をパックしたもの)とバッチ情報ファイルが追加される。

3 ■重要 この1.0004のbinフォルダを、例えばbin10004などとリネームコピーしておく これをしておかないとダウングレードができない。

4 同様に1.0005・1.0006のパッチを当てる。 
■重要 その都度必ずbinフォルダをリネームコピーしておくこと。 これで1.0003から1.0006までのbinフォルダが揃った。

■重要 以下のパッチ情報ファイルを別の場所に保存するかパックして置く(patch.lzhなど)

p4.txt
p5.txt
p6.txt
Patch-any-4.txt
Patch-any-5.txt
Patch-5-6.txt

5 この状態でのバージョンは1.0006だが、ルートにはbinフォルダ5つある。

bin(現在は1.0006)
bin10003
bin10004
bin10005
bin10006

gamedata.db*は14

gamedata.db0
gamedata.db1
gamedata.db2
gamedata.db3
gamedata.db4
gamedata.db5
gamedata.db6
gamedata.db7
gamedata.db8
gamedata.db9
gamedata.dba
gamedata.dbb
gamedata.dbc
gamedata.dbd

パッチ情報ファイルは以下の6つ(パッケージのメーカーによってはファイル名が異なる場合もある)
p4.txt
p5.txt
p6.txt
Patch-any-4.txt
Patch-any-5.txt
Patch-5-6.txt

------------------------------------------------------
■ダウングレードの手順 現状の1.0006から1.0005に落とす場合

0 ■重要 14あるgamedata.db*を他の場所に保存 但し削除しない場合はこの作業は不要だが、念のため保存しておくことをお勧めする。 サイズはかなりでかいので要注意。

1 パッチ情報ファイルの1.0006対応のものを削除する 上の例では
p6.txt 及び Patch-5-6.txt

2 現在のbinフォルダ(1.0006のもの)を削除する

3 bin10005フォルダをbinにリネームコピーする

4 gamedata.dbdは1.0006のアーカイブファイルだが、1.0005では不要 
これを削除するよう勧めている人もいたが、私の場合はのまま置いておいても特に問題は無かった

■重要 削除する場合は必ずどこかへ保存しておく これをしないと元に戻せない!

1.0005から1.0004へのダウングレードも上と同じ手順である。

2



コメントを書く

名前
メールアドレス
コメント本文(1000文字まで)
URL





AutoPage最新お知らせ